GRBLShield specs incorrect?

GRBLShield specs incorrect?

Postby Pseudo » Sat Aug 18, 2012 7:29 am

Ok, so the X-axis chip on my grblshield stopped responding to direction input and I looked into buying a replacement. According the synthetos site and the markings on the chip it's a DRV8811.
Synthetos claims 2.5A per winding for the chip, but the TI site claims 1.9 (http://www.ti.com/product/drv8811). Its big brother, the 8818 IS 2.5A however (http://www.ti.com/product/drv8818).

So have I made a mistake somewhere or is the data about the grblshield incorrect?
Pseudo
 
Posts: 15
Joined: Thu Jun 21, 2012 10:30 am

Re: GRBLShield specs incorrect?

Postby aldenhart » Sun Aug 19, 2012 9:51 pm

No, the specs for the grblShield are correct, or at least they were until TI changed the ratings on the DRV8811. TI rated the 8811 at 2.5 amps, so that's what we did. We've been running them that high, but we've always recommended fan cooling above about 2 amps. So it sounds like TI has caught up to our caution.

The DRV8818 is a new product that appears to be a pin compatible with the DRV8811's. I'll order some and beat them up to see if they perform better than the DRV8811's at high currents.

Alden
aldenhart
 
Posts: 129
Joined: Tue Apr 10, 2012 2:17 pm

Re: GRBLShield specs incorrect?

Postby Pseudo » Mon Aug 20, 2012 8:20 am

Ah, cheers Alden; helpful as always :)
Pseudo
 
Posts: 15
Joined: Thu Jun 21, 2012 10:30 am


Return to Electronics

Who is online

Users browsing this forum: No registered users and 2 guests