Basic workflow 3D

From ShapeOko
Jump to: navigation, search

Open Source CAD/CAM Stack


For a tutorial on creating a basic 2D workflow, see here


Create part file

This can be done w/ any CAD application which can export to a format which your CAM program can interpret (the example below uses STP). There is a basic example part on the OpenSCAD page. Other choices include FreeCAD, SketchUp, &c.

Create toolpaths with HeeksCNC

  1. Use File -> Import to open STP/STEP file. The Objects pane on the left will show "STEP solid" entry.
  2. Right click on face of Solid to get a pop-up menu.
  3. Select Face -> Make a sketch from Face. A "sketch" entry will appear in the Objects pane.
  4. Right click on the sketch in Objects pane, select 'Split Sketch'. You now have two separate sketches listed in the Object pane. If your solid is more complex you may have several sketches listed. (There is one sketch for each machining operation the face will require. If you select a sketch it will highlight on the drawing).
  5. Select an inside profile (its outline turns darker).
  6. Click Machining -> Add New Milling Operation -> Pocket Operation -> Fill in details -> Click OK
  7. An entry for the machining operation will be added in the Objects pane under "Operations".
  8. Click Machining -> G0 (Post Process) - your toolpath will show as a green line in the drawing window (a DOS box pops up, then disappears). If the toolpath doesn't show up there is a conflict between the tool size and the object's geometry (the tool is too big a diameter typically).
  9. Select the next inside profile and define a pocket operation for it. In general do the pocket operations first just in case the part breaks free while doing the profile operation.
  10. Select the outside profile (outline will turn darker)
  11. Click Machining -> Add New Milling Operation -> Profile Operation (no window pops up) - control output via Properties pane in lower left
  12. Select 'Outside' for 'Tool on Side'
  13. Make sure your final depth is the thickness of your material.
  14. Select the appropriate tool
  15. Add part holding Tags on the profile operations, right click on the profile operation in the Objects pane, select Add Tag, in the Properties window is a button for "Pick position". Click on the drawing in the approximate spot where you need a holding tag. Add tags as needed.
  16. Click Machining -> G0 (Post Process) - your toolpath will show (DOS box pops up, then disapears)
  17. At the bottom of your screen you will see the actual g-code output. You can copy and paste that to a text file. OR, click Machining -> Save nc File.

Defining and saving tool types:

  1. Right click on Tools in the object pane.
  2. Select New End Mill (or New whatever tool type you need)
  3. Fill in the information on the tool
  4. Click the green checkmark in the Properties tab when you have the tool defined
  5. To save the tool in the default set: Right click on Tools, select Export, save in the default location with the file name default.tooltable.

Reordering machining operations:

  1. You can click-drag the Pocket and Profile entries in the Operations list to reorder the operations.

Video

[1]

Simulate toolpaths with OpenSCAM

  1. Click File-> Open
  2. Find the NC file you saved from HeeksCNC
  3. OpenSCAM will process the file, resulting in what the part will look like *finished*
  4. There is a slider bar in the middle of the left hand window, slide that all the way to the left. Toggle the direction arrow to the right
  5. Click Edit -> Project
  6. Add a new tool: Click +, define tool at 10mm length 3.175mm diameter. Make note of the tool number!
  7. Open your NC file and find out what tool it's expecting to find. Towards the top you'll see the T command. Maybe T16?
  8. In the NC file, change the T# to match the tool you just created in OpenSCAM. Save your NC file. You will notice OpenSCAM re-rendering the toolpaths to accomdate the change in cutter size.
  9. Switching back over to OpenSCAM: Click the 'Play Button' under the 'Animate Toolpath' Section.
  10. Watch in amazement!
  11. If you are impatient, click the fast forward button, directly to the right of the 'Play button' to speed things up.

Run your job with a G-Code Communication/Control Program

Please see Run the Job on the Workflow page.