Universal Gcode Sender incorrectly displaying gcode programs

Universal Gcode Sender incorrectly displaying gcode programs

Postby n1kt0 » Sun Dec 22, 2013 8:30 pm

Hello everyone. I'm still kind of new at this, and I'm looking for a little guidance as far as generating gcode programs that Universal Gcode Sender/GRBL can interpret correctly.

I downloaded F-engrave this afternoon and started playing around with it, but I've found that the .ngc files it generates do not display correctly in Universal Gcode Sender.


Image
Here you can see the default settings and placeholder text that comes up when you launch F-engrave. I have not changed any settings from default; I simply selected the V-carve radio button and calculated and saved the gcode program it generated.



Image
Here's what results when I load and visualize the same gcode program in Universal Gcode Sender.

Does anyone have any idea why this happens? Is F-engrave generating gcodes that UGCS doesn't support? Are there any fixes or workarounds that will allow these programs to play nicely together? I also had trouble viewing a gcode file generated by dxf2gcode; this time the visualizer just remained blank, and when I tried to stream the file to my GRBL, it just sat there and did nothing.

Here's the gcode file that F-carve generated, if anyone's curious: text.ngc
n1kt0
 
Posts: 2
Joined: Fri Dec 13, 2013 12:55 am

Re: Universal Gcode Sender incorrectly displaying gcode prog

Postby Will Winder » Mon Dec 23, 2013 6:17 pm

The "G91.1" command at the beginning is causing this problem, my gcode parser assumes that commands are always whole numbers so things go sideways when that shows up. I'm adding a bug for this to fix later.
ShapeOko #367: Dual-Y drive, Belt on outside, 1000mm Y-Axis, DW660 Spindle, Nema-23 X/Y motors.

Primary developer on Universal Gcode Sender.
Will Winder
 
Posts: 435
Joined: Fri Apr 20, 2012 2:40 pm
Location: Hudson, MA

Re: Universal Gcode Sender incorrectly displaying gcode prog

Postby WillAdams » Wed Feb 12, 2014 8:56 pm

Turns out this isn't supported in GRBL either:

http://www.shapeoko.com/wiki/index.php/ ... _with_GRBL
Shapeoko 3XL #0006 w/Makita RT0701 Router w/0.125″ and ¼″ Elaire precision collets
Nomad 883 Pro #596 (bamboo)
WillAdams
 
Posts: 8016
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15


Return to Software - CAD, CAM, Workflow Help

Who is online

Users browsing this forum: No registered users and 1 guest